Харьков Форум
  Харьков Форум > Hi-Tech... > Софт

Старый 14.04.2019, 18:59   #1
Schmutz


 
 
Регистрация: 16.11.2006
Адрес: Третья планета от солнца
Из: Ukraine
Сообщений: 2,400
 
По умолчанию Скрипт для проверки доступа к интернет на Mikrotik

имеется девайс Mikrotik951Ui-2HnD. есть желание, чтоб писался лог когда отваливается сеть. писался чтоб на флэшку, дабы не засирать память. но т.к с линуксом у меня проблемы, поэтому обращаюсь к вам.
вот что нашел в сети:


##### Script Settings #####
:local WanName "pppoe-bn.by"
:local HostPingA "8.8.8.8"
:local HostPingB "8.8.4.4"
#####################

:local PingCount "5"
:local WanStat
/interface pppoe-client monitor $WanName once do={ :set WanStat $status}
:if ($WanStat = "connected") do={
:local pingresultA [/ping $HostPingA count=$PingCount interface=$WanName];
:if ($pingresultA = 0) do={
:local pingresultB [/ping $HostPingB count=$PingCount interface=$WanName];
:if ($pingresultB = 0) do={
:log error message="Script can not ping through <$WanName>. 8.8.8.8 answered $pingresultA times, 8.8.4.4 answered $pingresultB times.";
:interface pppoe-client disable $WanName;
elay 5; #вот собака смайлик втулило, ну вы поняли : d без пробела
:interface pppoe-client enable $WanName;
:log warning message="<$WanName> has reconnected by script";
}
}
}


это будет работать?
что сюда нужно добавить, чтоб писалось на флэшку, USB роутера?
WanName - здесь должно быть имя моего Wan-порта?

пы.сы. 3 года назад настраивал роутер и туда больше не заглядывал. многое стерлось из памяти, да и многого не постиг. так что заранее прошу прощения за нубские вопросы.

источник


__________________
Правильно воспитанная совесть никогда не будет грызть своего хозяина.
    Вверх

Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск

Харьков Форум > Hi-Tech... > Софт

Быстрый переход

Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Скрипт для интернет магазина- какой? S.F.W. Программирование и создание сайтов 39 23.11.2012 14:00
Какая скорость для домашнего доступа к сети Интернет для Вас достаточна на сегодняшний день? lex--us Интернет и локальные сети 77 30.06.2010 12:37
Скрипт интернет магазина. n()[email protected] Интернет и локальные сети 4 14.03.2010 05:52


Часовой пояс GMT +2, время: 06:20.


Харьков Форум Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.